Вторник, 24 апреля 2018 16 +   Подписка на обновления  RSS  Письмо редактору
Популярно
В OpenSSL закрыли критическую уязвимость 16-летней давности
3:35, 02 мая 2015

В OpenSSL закрыли критическую уязвимость 16-летней давности


В криптографическом пакете OpenSSL обнаружена и исправлена очередная серьёзная уязвимость CVE-2014-0224. С её помощью злоумышленник может специальным образом подобрать параметры рукопожатия, чтобы клиент и сервер OpenSSL SSL/TLS использовали для связи между собой слабые ключи, не обеспечивающие должной безопасности.

Ослабив таким образом канал, злоумышленник имеет возможность провести атаку типа «человек посередине» (MiTM), расшифровать и модифицировать трафик между клиентом и сервером.

Проведение атаки возможно только в том случае, если обе стороны используют уязвимую версию библиотеки OpenSSL. Уязвимыми являются все клиентские версии OpenSSL, и из серверных пакетов — только OpenSSL 1.0.1 и 1.0.2-beta1. Тем не менее, пользователям более ранних серверных версий тоже рекомендуется обновиться на всякий случай.

Более подробно механизм эксплуатации объясняет японский специалист Макаси Кукичи (Masashi Kikuchi), который обнаружил этот баг.

Проблема заключается в некорректной обработке спецификаций ChangeCipherSpec (CCS) в OpenSSL во время рукопожатия. Причём баг существовал с момента самого первого выпуска криптографического пакета 16 лет назад.

Некорректная обработка заключается в том, что OpenSSL отправляет пакеты CCS по строгому графику в определённый момент рукопожатия, а вот обрабатывает принятые пакеты и в другое время. Злоумышленник может воспользоваться этим, чтобы внедриться в передачу со своими CSS и ослабить установленные ранее договорённости об использовании конкретных шифров.

Правильный порядок рукопожатия изображён на схеме. Нужно всего лишь вставить в код проверку, что этот порядок соблюдается.

В новых версиях 0.9.8za, 1.0.0m и 1.0.1h исправлена эта и ещё несколько уязвимостей в OpenSSL.

Оригинальный текст:

OpenSSL Security Advisory [05 Jun 2014]
========================================

SSL/TLS MITM vulnerability (CVE-2014-0224)
===========================================

An attacker using a carefully crafted handshake can force the use of weak
keying material in OpenSSL SSL/TLS clients and servers. This can be exploited
by a Man-in-the-middle (MITM) attack where the attacker can decrypt and
modify traffic from the attacked client and server.

The attack can only be performed between a vulnerable client *and*
server. OpenSSL clients are vulnerable in all versions of OpenSSL. Servers
are only known to be vulnerable in OpenSSL 1.0.1 and 1.0.2-beta1. Users
of OpenSSL servers earlier than 1.0.1 are advised to upgrade as a precaution.

OpenSSL 0.9.8 SSL/TLS users (client and/or server) should upgrade to 0.9.8za.
OpenSSL 1.0.0 SSL/TLS users (client and/or server) should upgrade to 1.0.0m.
OpenSSL 1.0.1 SSL/TLS users (client and/or server) should upgrade to 1.0.1h.

Thanks to KIKUCHI Masashi (Lepidum Co. Ltd.) for discovering and
researching this issue.  This issue was reported to OpenSSL on 1st May
2014 via JPCERT/CC.

The fix was developed by Stephen Henson of the OpenSSL core team partly based
on an original patch from KIKUCHI Masashi.

DTLS recursion flaw (CVE-2014-0221)
====================================

By sending an invalid DTLS handshake to an OpenSSL DTLS client the code
can be made to recurse eventually crashing in a DoS attack.

Only applications using OpenSSL as a DTLS client are affected.

OpenSSL 0.9.8 DTLS users should upgrade to 0.9.8za
OpenSSL 1.0.0 DTLS users should upgrade to 1.0.0m.
OpenSSL 1.0.1 DTLS users should upgrade to 1.0.1h.

Thanks to Imre Rad (Search-Lab Ltd.) for discovering this issue.  This
issue was reported to OpenSSL on 9th May 2014.

The fix was developed by Stephen Henson of the OpenSSL core team.

DTLS invalid fragment vulnerability (CVE-2014-0195)
====================================================

A buffer overrun attack can be triggered by sending invalid DTLS fragments
to an OpenSSL DTLS client or server. This is potentially exploitable to
run arbitrary code on a vulnerable client or server.

Only applications using OpenSSL as a DTLS client or server affected.

OpenSSL 0.9.8 DTLS users should upgrade to 0.9.8za
OpenSSL 1.0.0 DTLS users should upgrade to 1.0.0m.
OpenSSL 1.0.1 DTLS users should upgrade to 1.0.1h.

Thanks to Jüri Aedla for reporting this issue.  This issue was
reported to OpenSSL on 23rd April 2014 via HP ZDI.

The fix was developed by Stephen Henson of the OpenSSL core team.

SSL_MODE_RELEASE_BUFFERS NULL pointer dereference (CVE-2014-0198)
=================================================================

A flaw in the do_ssl3_write function can allow remote attackers to
cause a denial of service via a NULL pointer dereference.  This flaw
only affects OpenSSL 1.0.0 and 1.0.1 where SSL_MODE_RELEASE_BUFFERS is
enabled, which is not the default and not common.

OpenSSL 1.0.0 users should upgrade to 1.0.0m.
OpenSSL 1.0.1 users should upgrade to 1.0.1h.

This issue was reported in public.  The fix was developed by
Matt Caswell of the OpenSSL development team.

SSL_MODE_RELEASE_BUFFERS session injection or denial of service (CVE-2010-5298)
===============================================================================
 
A race condition in the ssl3_read_bytes function can allow remote
attackers to inject data across sessions or cause a denial of service.
This flaw only affects multithreaded applications using OpenSSL 1.0.0
and 1.0.1, where SSL_MODE_RELEASE_BUFFERS is enabled, which is not the
default and not common.

OpenSSL 1.0.0 users should upgrade to 1.0.0m.
OpenSSL 1.0.1 users should upgrade to 1.0.1h.

This issue was reported in public. 

Anonymous ECDH denial of service (CVE-2014-3470)
================================================

OpenSSL TLS clients enabling anonymous ECDH ciphersuites are subject to a
denial of service attack.

OpenSSL 0.9.8 users should upgrade to 0.9.8za
OpenSSL 1.0.0 users should upgrade to 1.0.0m.
OpenSSL 1.0.1 users should upgrade to 1.0.1h.

Thanks to Felix Grö
bert and Ivan Fratric at Google for discovering this
issue.  This issue was reported to OpenSSL on 28th May 2014.

The fix was developed by Stephen Henson of the OpenSSL core team.

Other issues
============

OpenSSL 1.0.0m and OpenSSL 0.9.8za also contain a fix for
CVE-2014-0076: Fix for the attack described in the paper «Recovering
OpenSSL ECDSA Nonces Using the FLUSH+RELOAD Cache Side-channel Attack»
Reported by Yuval Yarom and Naomi Benger.  This issue was previously
fixed in OpenSSL 1.0.1g.

References
==========

URL for this Security Advisory:
www.openssl.org/news/secadv_20140605.txt

Note: the online version of the advisory may be updated with additional
details over time.

Об авторе: profiremont


Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

© 2018 Информационно новостные статьи